Page 1 of 1

AForge.Video.FFMPEG dependency on .Net 3.5

PostPosted: Fri May 26, 2017 7:43 pm
by Arif
I have been using VideoFileWriter call from AForge.Video.FFMPEG in a C# application that is targeted to
Dot net 4.5. I get a run-time error if Dot net 3.5 not installed
"Could not load file or assembly 'Accord.Video.FFMPEG.dll' or one of its dependencies. The specified module could not be found."

Trying to understand where this Dot Net 3.5 dependency coming from. Is it something in the ffmpeg wrapper that need Dot net 3.5, though my application is targeted to 4.5.

BTW, I have all the dependency dll in the same directory as myexecutable, so it works fine if .net 3.5 is installed

Re: AForge.Video.FFMPEG dependency on .Net 3.5

PostPosted: Sat May 27, 2017 7:30 am
by andrew.kirillov
You can re-build all AForge.NET DLLs using .NET version you like.