AForge.NET

  :: AForge.NET Framework :: Articles :: Forums ::

AForge.Video.FFMPEG dependency on .Net 3.5

Forum to discuss AForge.NET Framework, its features, API, how-tos, etc.

AForge.Video.FFMPEG dependency on .Net 3.5

Postby Arif » Fri May 26, 2017 7:43 pm

I have been using VideoFileWriter call from AForge.Video.FFMPEG in a C# application that is targeted to
Dot net 4.5. I get a run-time error if Dot net 3.5 not installed
"Could not load file or assembly 'Accord.Video.FFMPEG.dll' or one of its dependencies. The specified module could not be found."

Trying to understand where this Dot Net 3.5 dependency coming from. Is it something in the ffmpeg wrapper that need Dot net 3.5, though my application is targeted to 4.5.

BTW, I have all the dependency dll in the same directory as myexecutable, so it works fine if .net 3.5 is installed
Arif
 
Posts: 1
Joined: Fri May 26, 2017 7:39 pm

Re: AForge.Video.FFMPEG dependency on .Net 3.5

Postby andrew.kirillov » Sat May 27, 2017 7:30 am

You can re-build all AForge.NET DLLs using .NET version you like.
With best regards,
Andrew


Interested in supporting AForge.NET Framework?
User avatar
andrew.kirillov
Site Admin, AForge.NET Developer
 
Posts: 3453
Joined: Fri Jan 23, 2009 9:12 am
Location: UK




Return to AForge.NET Framework